Unoconv en linux CentOS 7 o Ubuntu

Unoconv es el enombre abreviado de “Universal Office Converter“, una librería de utilidad para convertir documentos comunes de Microsoft Office, Apache OpenOffice, es decir .doc, .odt, etc de un formato a otro.

Existen varias versiones y probablemente por defecto, la tengamos instalada en el sistema operativo linux. Esto se produce cuando instalamos un programa como OpenOffice, ya que las librerias suelen estar incluidas en este software. Ejemplo de uso:

unoconv -f pdf sample.doc (Convierte de DOC a PDF)

Para instalar la versión por defecto del repositorio, puedes utilizar los siguiente comandos para linux Ubuntu o CentOS, siempre logueados en el sistema como administrador:

yum install unoconv (Para CentOS)* apt-get install unoconv (Para Ubuntu)

*Puedes usar el comando yum install unoconv openoffice.org-headless openoffice.org-writer openoffice.org-calc openoffice.org-impress para instalar todos los paquetes de OpenOffice.

Consultamos la versión de unoconv en nuestro linux:

unoconv --version (Obtenemos la versión de unoconv) ========== SALIDA POR TERMINAL =========
unoconv 0.6
Written by Dag Wieers
Homepage at http://dag.wieers.com/home-made/unoconv/
platform posix/linux2
python 2.7.5 (default, Apr 2 2020, 13:16:51)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]
LibreOffice 5.3

No obstante, si queremos reinstalar una versión más reciente de unoconv, podemos hacerlo utilizando una fuente de terceros, no siendo la oficinal instalada en la versión de CentOS 7 en este caso.

Si buscas unoconv version 07, encontrarás la última versión en la propia página de la versión instalada http://dag.wieers.com/home-made/unoconv/ o en esta página: https://centos.pkgs.org/7/cheese-x86_64/unoconv-0.9.0-4.el7.noarch.rpm.html

Para realizar la instalación, descargaremos el paquete obtenido en las páginas anteriores a la carpeta temporal /tmp/. Ejemplo:

wget http://www.nosuchhost.net/~cheese/fedora/packages/epel-7/x86_64/unoconv-0.9.0-4.el7.noarch.rpm (descargamos el archivo)
yum localinstall ./unoconv-0.9.0-4.el7.noarch.rpm (instalamos)

Si tienes suerte, se instalará, pero si tienes dependencias, tendrás que instalar las dependencias que falten.

Marcar como favorito enlace permanente.

Comentarios cerrados.